Informatica 9.1 Installation could not start _AdminConsole

Installing Informatica with the installer was straightforward, but for some strange reason the adminconsole could not be started. Here the output I found in the Logfile:

INFA_HOME/tomcat/logs/node.log
 2012-08-08 12:17:45,294 ERROR [Thread 6 of 6 in DomainServiceThreadPool] [SPC_10013] Prozess für Dienst _AdminConsole konnte nicht gestartet werden.
 2012-08-08 12:27:41,524 ERROR [Thread 6 of 6 in DomainServiceThreadPool] [SPC_10013] Prozess für Dienst _AdminConsole konnte nicht gestartet werden.
 2012-08-08 12:42:07,275 ERROR [Thread 6 of 6 in DomainServiceThreadPool] [SPC_10013] Prozess für Dienst _AdminConsole konnte nicht gestartet werden.

this is not very helpful, but in the following logfile I found a clue:

INFA_HOME/services/AdministratorConsole/administrator.log

2012-08-08 11:40:45,103 ERROR [org.apache.catalina.core.ContainerBase.[_AdminConsole].[localhost].[/administrator]] Exception sending context initialized event to listener instance of class com.informatica.adminconsole.app.config.CustomChainListener
java.lang.RuntimeException: Exception parsing chain config resource ‘/WEB-INF/chain-config.xml’: /..INFA_HOME../services/AdministratorConsole/administrator/WEB-INF/chain-config.xml (Too many open files)
at org.apache.commons.chain.web.ChainResources.parseWebResources(ChainResources.java:194)
at org.apache.commons.chain.web.ChainListener.contextInitialized(ChainListener.java:221)
at com.informatica.adminconsole.app.config.CustomChainListener.contextInitialized(CustomChainListener.java:32)
at org.apache.catalina.core.StandardContext.listenerStart(StandardContext.java:3795)
at org.apache.catalina.core.StandardContext.start(StandardContext.java:4252)
at org.apache.catalina.core.StandardContext.reload(StandardContext.java:3056)
at org.apache.catalina.loader.WebappLoader.backgroundProcess(WebappLoader.java:432)
at org.apache.catalina.core.ContainerBase.backgroundProcess(ContainerBase.java:1278)
at org.apache.catalina.core.ContainerBase$ContainerBackgroundProcessor.processChildren(ContainerBase.java:1570)
at org.apache.catalina.core.ContainerBase$ContainerBackgroundProcessor.processChildren(ContainerBase.java:1579)
at org.apache.catalina.core.ContainerBase$ContainerBackgroundProcessor.processChildren(ContainerBase.java:1579)
at org.apache.catalina.core.ContainerBase$ContainerBackgroundProcessor.run(ContainerBase.java:1559)
at java.lang.Thread.run(Thread.java:662)

So to fix the problem you have to increase the open file descriptor limits.
http://www.cyberciti.biz/faq/linux-increase-the-maximum-number-of-open-files/

#$ sysctl -w fs.file-max=100000

#$ vi /etc/sysctl.conf

add the line:

fs.file-max = 100000

#$ sysctl -p

#$ vi /etc/security/limits.conf

Add the lines for your informatica user (e.g. informatica)
informatica soft nofile 4096
informatica hard nofile 10240

or if you are not sure for all users:

* soft nofile 4096 * hard nofile 10240

Restart the server and it should work. Or do:

http://lzone.de/apply+limits+immediately

Here is a little tip how I found interesting logfiles in the Informatica-Home-Directory:
This gives all files with ending “log” and the line count

find . -name "*.log" | xargs wc -l
 0 ./servicesFramework.log
 0 ./isp/bin/servicesFramework.log
 0 ./services/AdministratorConsole/monitoring.log
 15 ./services/AdministratorConsole/administrator.log
 0 ./server/servicesFramework.log
 0 ./tomcat/webapps/csm/output/csm.log
 367 ./tomcat/logs/node.log
 264 ./tomcat/logs/exceptions.log
 0 ./tomcat/temp/_AdminConsole/logs/host-manager.2012-08-08.log
 0 ./tomcat/temp/_AdminConsole/logs/manager.2012-08-08.log
 55459 ./tomcat/temp/_AdminConsole/logs/catalina.2012-08-08.log
 0 ./tomcat/temp/_AdminConsole/logs/admin.2012-08-08.log
 0 ./tomcat/temp/_AdminConsole/logs/localhost.2012-08-08.log
 622 ./tomcat/bin/ispLogs.log
 676 ./tomcat/bin/servicesFramework.log
 0 ./tomcat/bin/infa_jsf.log
 402 ./Informatica_9.1.0_Services_HotFix4.log
 297 ./Informatica_9.1.0_HotFix4_Services_InstallLog.log
pixelstats trackingpixel

Comments (1)

TuhinOctober 21st, 2013 at %I:%M %p

Hi,

I have installed informatica9.1 in my Linux VM, and the installation completed successfully. During installation i was able to connect to Admin web-page.

But, once i restarted my VM, I was not able to login Adminpage.

I am new to informatica

Please help.

Leave a comment

Your comment

Time limit is exhausted. Please reload the CAPTCHA.